Fare thee well, Postgres 7

Drupal 7 is shaping up to be the most modern Drupal ever! (Now there's a silly title if I ever heard one...) Not only are we upping the system requirements to PHP 5.2 and MySQL 5.0, but PostgreSQL users will now need PostgreSQL 8.1 at least.

Given that PostgreSQL 7.4 is slated for retirement by the end of this year and Drupal 7 won't ship until 2009 sometime, that is not as massive a change as it might sound, but it's still a good sign for the web that people are moving forward and embracing new technologies rather than being hamstrung by older software. That also makes developing software a lot easier, as we can leverage features found only in new versions and ignore bugs in older versions. :-)

Rock on!